Palm Pre und Exchange zum Laufen bekommen

Wer dieses Blog schon eine Zeit liest, der kennt meine grundsätzlichen Probleme rund um "mal eben". Wann immer ich in engem Zeitkorsett entscheide, dass ich irgendetwas "mal eben" machen kann, geht es in die Hose. So auch heute.

Vollkommen unvorbereitet betrete ich einen O2-Shop, sehe ein Ausstellungsstück des Palm Pre, nehme es in die Hand... und bin wider meiner Vorsätze gebannt. Wahrscheinlich hätte ich mich ja noch beherrscht, aber nachdem der Shopinhaber meinte "Kann ich erst ab morgen verkaufen" (zeigt auf das O2-Werbeplakat mit dem Aufdruck "Ab 13.10.2009 exklusiv bei O2") war mein Jagdtrieb geweckt. 5 Minuten später waren wird uns mit "Bar zahlen, Rechnung schick ich nach, dann kann ich ihn erst morgen buchen" einig... :-)

Das "male eben" war dann der Versuch der Einrichtung des Exchange-Zugangs. WebOS ist ... sagen wir mal ... gewöhnungsbedürftig, egal, ob man vorher ein Windows Mobile-Gerät, ein iPhone oder eine Symbian-Telefonzelle hatte. Grundsätzlich war das Postfach schnell eingerichtet, grundsätzlich der Frustfaktor aber auch schnell hoch: "Das Zertifikat ist ungültig oder Datum und Uhrzeit stimmen nicht" war die Meldung des Tages... und auch nach einer Stunde Wühlen durch die englischen Foren der Mitleidenden in den USA (die seit einigen Monaten bereits in den Genuß des Palm Pre kommen) war mir klar, dass es am Zertifikat liegt, was bei meinem Server ein selbst generiertes ist. Nach einigem weiteren Suchen und Ausprobieren hier meine Lösung, um den Exchange ActiveSync (EAS) zum Laufen zu bekommen:

1.) Bereitstellen des Root-Zertifikats

Der Pre besteht darauf, das Root-Zertifikat des Servers (und nicht des Exchange) zu haben. Gut gelaufen, wenn der Admin direkt das Root-Zertifikat exportiert hat (das dann natürlich auch für den Exchange gilt), schlecht, wenn nicht. Hier ist ggf. eine Abstimmung mit dem Serveradministrator von Nöten, der das Zertifikt als Datei erstellen muss.

2.) OWA funktioniert nicht zur Zertifikatsinstallation

Klassischer, aber (zumindest bei mir) wenig hilfreicher Tipp: Den Server im Outlook Web Access (OWA) ansurfen und dort das Zertifikat bei der Zertifikatswarnung akzeptieren. OWA funktioniert, EAS aber immer noch nicht.

3.) Mailen des Zertifikats

Hat man einmal das Zertifikat (in Form einer Datei der Endung ".cer"), dann muss es auf den Pre gelangen. Auch hier wieder ein für mich erfolgloser, aber oft gelesener Weg: In das Hauptverzeichnis des Wechseldatenträgers (aka Speicher des Pre) legen und neu starten.

Der funktionierende Weg ist gar noch einfacher: Einfach eine Mail mit der Zertifikatsdatei als Anhang senden, am besten an ein Freemail-Postfach (bei mir Yahoo), denn der Exchange bzw. OWA verweigert eine solche Datei als "unsichere Anlage". Ist aber das Freemail-Postfach auf dem Pre konfiguriert, dann kann es abgerufen werden, dann der Anhang geöffnet werden. Es öffnet sich automatisch der Zertfikatsmanager des Pre, dort das Zertifikat akzeptieren, einmal neu starten, EAS neu einrichten und freuen... :-D

Dieser Beitrag wurde geschrieben von am Dienstag, 13. Oktober 2009 um 00:44 und eingeordnet unter Blog , Kommunikation .

Kategorien

Cookies helfen uns bei der Bereitstellung unserer Dienste. Durch die Nutzung unserer Dienste erklären Sie sich damit einverstanden, dass wir Cookies setzen.